Web Browser Update

JC - 1x1.jpg

Effective July 31, 2019, internet browsers running on versions of Transport Layer Security (TLS) older than versions 1.2 will be blocked by Fidelity’s websites. Please upgrade your web browser to the minimum versions shown below:

  • Microsoft Internet Explorer, version 11

  • Google Chrome, version 30

  • Mozilla Firefox, version 27

  • Apple Safari, version 7

Links for instructions on how to update your respective web browser can be found by clicking on the name of your current web browser provider. If you have any questions or need any assistance please contact Jaycee Smalley at 713-388-6322 or jsmalley@newcapitalmgmt.com.


We’d Love To Hear From You

Name *
Name
Phone
Phone